My linux mint machine does not recognize the Ledger Nano S wallet

Bitcoin Questions and AnswersCategory: General questionsMy linux mint machine does not recognize the Ledger Nano S wallet

I just received my Ledger Nan S wallet today but my Linux Mint machine does not recognize it.

Googling the problem, I found only one solution here ) and all the other pages refer to the same solution in a way or another.
I followed the steps in the previous link but it did not work also.
Any idea

Dave Hodge replied 8 months ago

You should list the command since the link is dead

John replied 9 months ago

My linux ubuntu machine does not recognise the ledger nano s wallet either

4 Answers
Steven Hay answered 9 months ago

Hi Anas,
 
Sorry, I don’t know how to solve this besides the instructions you linked. I suggest contacting Ledger support.

Benoit answered 9 months ago

Hi.
Worked for me once command has been executed as super user : su.
 

Ledgeruser answered 2 months ago

LINUX DOES NOT RECOGNIZE LEDGER NANO S – SOLVED
I struggled with this for months and finally found a fix that works every time. I thought some kernel updates had finally fixed the problem for good, but I noticed that after one reboot, the machine couldn’t see my nano again.
THE FIX: It’s so stupid, you’ll smack yourself (if it works for you, that is). I’m assuming you’ve tried everything else already, and that you’ve run the script from Ledger that adds the udev rules, etc, etc.

  1. Plug in your nano to the PC’s USB port and unlock it by entering your pin. Leave it unlocked and go to step 2 right away.
  2. Reboot the pc  (the computers I’ve tested this on kept the nano powered through a reboot, so I think this is necessary)
  3. Try the Chrome apps/MEW now.

When I noticed that the lsusb command gave different results when the device was locked compared to when it was unlocked, I thought of how Linux sometimes needs to boot up with a USB peripheral plugged in to get it to recognize correctly. This didn’t occur to me, because the nano WAS plugged in… EVERY TIME I WAS STRUGGLING WITH THIS – IT WAS PLUGGED IN…… just not unlocked during reboot every time. I assume this is also why my testing kept giving me different results – sometimes I was rebooting with the Nano unlocked, sometimes when is was locked… but always plugged in – this is what threw me off the scent of the solution.
I hope this helps someone else who’s stuck here.
 
ledgeruser

Bitcoin Video Crash Course 

Join over 94,000 students and know all you need to know about Bitcoin. One email a day for 7 days, short and educational, guaranteed.

We hate spam as much as you do. You can unsubscribe with one click.