Multi Bit wallet password not working?

Bitcoin Questions and AnswersCategory: General questionsMulti Bit wallet password not working?

martin asked 10 months ago

Last updated on January 17th, 2018 at 10:34 am

Hi, I have multi-bit wallet that will not open with the correct password. I installed a fresh instance of multi-bit on a new computer and tried restore using my wallet-words. I was asked to create a new password which I did. The wallet was created fine and had the correct amount of BTC but was grayed out with the password screen. I entered the new password and it “failed to open”, tried the original p/w and same.
I have only basic knowledge of computers so need a pretty simple explanation. I tried the forums and most of the Q&A is way over my head.
Any suggestions would be greatly appreciated.  :)

1 Answers
Zsofia Elek answered 10 months ago

Hi Martin,
KeepKey stopped supporting Multibit last week, it is possible that you have login issues because of that. Here you can read more. I suggest you follow up with the support team how to resolve your issue, in the post you can also find a link to a walkthrough what to do in case of login issue, maybe you can start with that.

martin replied 10 months ago

Hi Zsofia, Thanks for your help. I tried creating a new Electrum wallet with my MultiBit wallet words and it worked fine. The BTC transaction history was imported and the coins are there so its all good news

Thanks again :)

Bitcoin Video Crash Course 

Join over 94,000 students and know all you need to know about Bitcoin. One email a day for 7 days, short and educational, guaranteed.

We hate spam as much as you do. You can unsubscribe with one click.